Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: cms2day Forum - Community & Support rund ums cms2day. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

1

Sonntag, 19. Februar 2012, 22:28

Minishop Modul - Bestellbestätigung

Beim letzten Schritt der Bestellung kommt bei mir irgendwie keine Meldung mit "Vielen Dank für Ihre Bestellung" oder sowas ähnliches.
Weiters bekommt man als Kunde keine Bestellbestätigung!

Link zum Shop: http://www.bodywork.at/index.php?seite=6.shop&action=artikel

Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von »fish« (10. März 2012, 17:22)


Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

2

Montag, 20. Februar 2012, 20:39

Bitte um Hilfe da ich den Shop sonst nicht online stellen kann.

Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

3

Dienstag, 21. Februar 2012, 09:32

Hab jetzt nochmal den Shop deinstalliert und die original Daten wieder hochgeladen (ohne Anpassungen).

Es funktioniert trotzdem noch nicht.
Er gibt mir in der Adressleiste folgendes aus: http://www.bodywork.at/index.php?seite=6.shop&action=bestellen&id=bestellen&id=bestellen

Werbung

JOE

Fortgeschrittener Benutzer

  • »JOE« ist männlich

Beiträge: 359

Paypal:

  • Nachricht senden

4

Dienstag, 21. Februar 2012, 16:32

Hi, wir haben Fasnacht, es kann gut sein das alle unterwegs sind, bitte gedulde dich bis Morgen, ich kann dir leider nicht helfen PHP ist nicht mein Ding, sorry. Aber es wird sich bis spätestens Morgen jemand darum kümmern.

Gruss JOE...



Signatur

Mancher lehnt eine gute Idee bloß deshalb ab, weil sie nicht von ihm ist!

Favorite Links
...............................................
SELFHTML
CSS4YOU
CSSMANIA
SELFPHP

Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

5

Dienstag, 21. Februar 2012, 16:51

Es kümmert sich schon wer drum!
Danke schonmal im vorraus an den Helfer :)

Werbung

emet

Admin & Support

  • »emet« ist männlich

Beiträge: 2 525

Wohnort: Rhein/Main

Paypal:

  • Nachricht senden

6

Dienstag, 21. Februar 2012, 16:56

OK. Ich habe jetzt mal getestet. Es kam keine Bestätigung und ich keine Mail.

Aber jetzt mal eine Bitte, da der Minishop umgebaut wurde und laut deiner Mail Probleme da waren mit Seo-Urls / ModRewrite.

Wir müssen die Änderungen ausschließen können, sonst können wir hier überhaupt nichts machen. (Da der Shop auf mehreren Installtionen einwandfrei läuft)

Bitte das Modul mit seinen Anpassungen sichern. Die Datenbank, Bilder etc Sichern usw. - damit später alles wieder aufgepielt werden kann.

Dann bitte mal den angepassten Shop im Backend deinstallieren und vom Server löschen. Dann bitte Original Minishop per FTP hochfahren und im Backend installieren - mal 2-3 Testprodukte drauf und bitte nochmal probieren - auch mal ModRewrite aktivieren.

Wenn die Sache mit dem ModRewrite wieder nicht geht - du hast ja den Link zu meiner Testinstall bekommen, wo es einwandfrei geht - dann frage ich mich, was der Hoster da alles eingestellt hat.

Zum Test könnte man auch mal ein Modul wie Kontaktformular testen mit und ohne ModRewrite, ob das mit der Spamschutzeingabe und versenden auf jede Art funzt. Weil es da bei falschen Einstellungen des Hostes unter Umständen auch Probleme geben kann (mit oder ohne - muss man sehen). Wenn das Kontaktformular geht, dann müssten auch die Mails verschickt werden. Ist hier der Standard belassen worden oder eine eigene Mailadresse eingegeben worden?

Evtl. liegt es an der PHP Version. Habe heute erzählt bekommen, das wegen eines ShopSystems von 5.3 auf 5.2 zurückgefahren wurde. Ich gehe aber nicht davon aus, das es die PHP Version selbst ist, sondern mit den Servereinstellungen zu tun hat, welche sich mit der neueren PHP Version so nicht vertragen.

Geht jetzt weder ModRewrite mit dem Original und auch die Bestellung wird nicht bestätigt und die Mail wird nicht versendet, dann stimmt was mit dem Server nicht.


.
.
HTML, was ist das? Ein neues Männermagazin? Css.., was es so alles gibt!

News: http://www.cms2day.de/news/1/
Features: http://www.cms2day.de/cms-funktionen/

Zufrieden mit cms2day und unserer Arbeit/Support - Spenden (-Button links) sind herzlich Willkommen - Dankeschön.
.

Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

7

Dienstag, 21. Februar 2012, 18:53

So habe nun nochmals den Shop deinstalliert, alle Files vom Server gelöscht und neu hochgeladen und installiert!

Bestellungbestätigung funktioniert nicht!

Habe dann ModRewrite eingeschalten, und auf einmal funktionierts.

Somit muss es irgendein Problem geben wenn ModRewrite nicht aktiv ist. Was ich auch so habe.

Kontaktformular funktioniert auch ohne ModRewrite.

Werbung

emet

Admin & Support

  • »emet« ist männlich

Beiträge: 2 525

Wohnort: Rhein/Main

Paypal:

  • Nachricht senden

8

Dienstag, 21. Februar 2012, 19:51

Also normal müsste es bei allen actions gleich sein - aber wenn eine Übergabe nur mit ModRewrite geht und ohne nicht, dann wird die action nicht angehängt bzw. vom Server nicht ausgeführt.

Das sind eigentlich Fehleinstellungen am Server. Ab und zu haben wir sowas ja schon mitbekommen und es lag jedesmal daran.

Ich schick dir jetzt nochmals die aktuellste install - überschreib die nochmal - weil bei mir gehts ja.
.
HTML, was ist das? Ein neues Männermagazin? Css.., was es so alles gibt!

News: http://www.cms2day.de/news/1/
Features: http://www.cms2day.de/cms-funktionen/

Zufrieden mit cms2day und unserer Arbeit/Support - Spenden (-Button links) sind herzlich Willkommen - Dankeschön.
.

Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

9

Dienstag, 21. Februar 2012, 20:10

Was für Servereinstellungen können es denn sein? Ist mein root also kein Problem zum ändern!

Werde die neue Install dann morgen vormittag probieren!

Werbung

fish

Schüler

  • »fish« ist männlich
  • »fish« ist der Autor dieses Themas

Beiträge: 70

Wohnort: Österreich

Beruf: Personal Trainer

Paypal:

  • Nachricht senden

10

Mittwoch, 22. Februar 2012, 07:58

So hab nun doch endlich auch auf ModRewrite gewechselt. Hab das mit den Bildern auf der Seite doch hinbekommen, woran ich immer gescheitert bin!

Jetzt hätte ich noch die Frage ob mann das irgendwie ändern kann, das in der URL nicht /1.seite/ steht sondern /seite/ ?

Werbung