Sie sind nicht angemeldet.

[kein Fehler] SEO - Links

Lieber Besucher, herzlich willkommen bei: cms2day Forum - Community & Support rund ums cms2day. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 19. Juli 2012, 21:07

SEO - Links

Hallo Gemeinschaft.

Ich hab nun das ganze Forum durchsucht und auch schon Google bemüht, doch irgendwie bin ich wohl zu blöd mein Problem selber zu lösen. ^^ ... Wundert euch nicht über die Domain. Das wird ein Projekt für die Schule und da man bei united-domains noch bis 31. Juli eine Domain für einen Jahrespreis (im 1. Jahr) von gerade mal 1 € registrieren kann hab ich das doch gleich mal investiert. :thumbsup:

Die Einstellungen erlauben ja die Möglichkeit suchmaschinenfreundliche Links zu erstellen. Das Ganze sieht bei mir so aus:



Wenn ich das nun aktiviere funktioniert es jedoch nicht und ich werde auf eine 404-Fehlerseite weitergeleitet, wenn ich den generierten SEO-Link dann aufrufen möchte.

Also hab ich mit Hilfe von Google und dem Forum hier herausgefunden, dass man dazu die mod_rewrite-Funktion braucht und hab durchs CMS mir die PHP-Info anzeigen lassen, die mir dann zeigt, dass das Modul eigentlich geladen worden ist.


Hab ich mich natürlich gewundert, wieso das denn nicht funktionieren mag. Total fraglos hab ich dann in das PHPmyadmin geschaut, was da denn so drinsteht. Und siehe da ... ich verstand nur noch Bahnhof. Das Modul mod_rewrite hab ich allerdings noch gefunden, doch aus dem was da drinsteht werde ich nicht ganz schlau.


Hab ich irgendwie die Möglichkeit eine der vier Einträge dort so zu bearbeiten, dass es einfach funktioniert, ohne großen Aufwand? :thumbup:

Bei meiner Suche hab ich noch gefunden, dass man eine .htaccess-Datei nehmen kann, um das Ganze irgendwie zu aktivieren. In der .htaccess-Datei steht drin:

#Do not remove this line, otherwise you can not use mod_rewrite.
RewriteBase /

Der feste Pfad zu meinem CMS ist:
http://www.javatu.de (ich hab kein Unterverzeichnis für das CMS angelegt, sondern alles ins Hauptverzeichnis gepackt.)

Über eure freundliche Hilfe bin ich sehr dankbar.

Liebe Grüße und danke für eure Bemühungen. :thumbsup:

Werbung

djknuffel

Moderator

  • »djknuffel« ist männlich

Beiträge: 710

CMS Version: 4.0.1

Wohnort: Frankfurt a.M.

Paypal:

  • Nachricht senden

2

Donnerstag, 19. Juli 2012, 22:28

setzt in den settings doch mal mod rewrite von inaktiv auf aktiv, dann greift auch die einstellung auy der zweiten hälfte der settings :-)
akrell.de - Informationen zu meinen Modulen für das cms2day System und meine Arbeiten als Hobbyfotograf

Werbung

3

Donnerstag, 19. Juli 2012, 23:58

Oh. Hoppla. Da hab ich doch glatt den Screen hochgeladen, wo ichs nicht aktiviert hatte. :D

Selbstverständlich - das Problem tritt auf, wenn ichs aktiviert hab. ^^

Folgendermaßen läuft das Ganze dann:

Ich stelle auf aktiviert und wähle die bevorzugte SEO-Link-Variante.



Danach rufe ich die Seite auf, und aktualisiere sie einmal, damit die neue Einstellung auch wirklich aktiviert wird. Das sieht dann nach Erfolg folgendermaßen aus:



Doch sobald ich diesen "neuen" Link dann aufrufen möchte werde ich auf die Fehlerseite des Hosters umgeleitet:



Entschuldige bitte die Verwirrung. *g*

Liebe Grüße :)

Werbung

djknuffel

Moderator

  • »djknuffel« ist männlich

Beiträge: 710

CMS Version: 4.0.1

Wohnort: Frankfurt a.M.

Paypal:

  • Nachricht senden

4

Freitag, 20. Juli 2012, 06:26

war mal eben auf der website deines hosters und hab ein wenig gesucht & gelesen ^ ^

kopiere dir mal die .htaccess datei die auf deinem webspace liegt und benennen sie in irgendwas um, nur damit das original erhalten bleibt, nach dem kopieren, lösche diese datei komplett vom server, öffne das admin backend vom cms und aktiviere seo

wenn ich nicht irre dann müsste das cms eine neue .htaccess anlegen mit den rewrite rules, diese neue .htaccess lädst dir runter vom webspace, öffnest diese mit einem editor, trägst in die erste zeile, sprich gaanz oben noch ein

RewriteBase /

speichern, wieder hochladen und gucken ob´s klappt
akrell.de - Informationen zu meinen Modulen für das cms2day System und meine Arbeiten als Hobbyfotograf

Werbung

Ähnliche Themen

Verwendete Tags

, , , , ,