Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: cms2day Forum - Community & Support rund ums cms2day. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 21. Juni 2009, 05:07

Mediathek will nicht

morgäähn, ich habe das cms in der aktuellen version installiert inklusive sämtlicher module etc. Alles funktioniert wunderbar (z.B. auch das Bilder einfügen über den ibrowser) aber die Mediathek leider nicht. Ich kann in dem Dropdownmenu im backend nichts auswählen, im ibrowser wird der inhalt des "media" ordners aber angezeigt.
liegt es evtl. an der reihenfolge der installation ( also erst ibrowser-addon dann mediathek geht / nicht ?) ???
gewundert hat mich auch, dass nach der installation die chmod rechte
des ordners immer noch auf 0 0 0 waren. habe sie dann auf 755 gesetzt,
was aber auch nichts geändert hat.
vielen dank im vorraus
der jottjott

Werbung

2

Montag, 22. Juni 2009, 01:05

habs eben noch einmal getestet und einfach das system ganz neu und als einziges modul die mediathek installiert, aber irgendwie geht sie immer noch nicht.

Werbung

3

Montag, 22. Juni 2009, 14:18

Eine etwas detailliertere Problembeschreibung wäre nötig.

Bekommst du irgendeinen (sichtbaren) Fehler? Wird die Datei in die Datenbank eingetragen aber nicht
hochgeladen? Oder umgekehrt? Oder gar nichts vo beidem?

Ausserdem sollte der Ordner, in welchen die Dateien abgelegt werden, die CHMOD 777 und nicht 755 haben.

Werbung

4

Montag, 22. Juni 2009, 19:23

OMG man sollte auch gucken können.... dennoch fragen

Problem Gelöst: Okay, das problem hat sich gelöst, ich war lediglich einfach zu blind und habe versucht [wie bei allen anderen modulen auch], über module > mediathek änderungen zu machen. In dem dortigen Dropdownmenu ging gar nichts. [Eben gerade habe ich dann den eigenständigen menüeintrag "mediathek" entdeckt, das uploaden geht einwadnfrei, danach kann man im Dropdownmenu Dateien auswählen, nice.] Das mit den nicht gesetzten Rechten war wohl auch nur ein Cache bzw. Aktualisierungsproblem.

Verbesserung:
Dieser Text aus der README.html des moduls sollte verbessert werden da hier ja die verwaltung bzw einstellungen des moduls nicht in der modulübersicht erfolgen.

Quellcode

1
Danach erscheint das Modul in der linken Menüleiste unter der Übersicht, wo es verwaltet wird. Moduleinstellungen finden Sie im Admin Backend unter Module - Übersicht - Klick auf den Modulnamen; falls diese in dem jeweiligen Modul vorhanden sind, erscheint dort ein Link zu den Einstellungen.


ABER: Mit dem I-browser konnte ich Dateien aus dem ordner "media" (welcher bei mir 755-rechte hat, 777 wäre zu viel) sehen, die ich lediglich per ftp und nicht über die mediathek hochgeladen habe. Daher dachte ich fälschlicher weise, dass ich diese dateien dann ja auch im dropdownmenu der mediathek haben sollte, das war nicht der fall.


abschlussFrage:
Also erkennt der Ibrowser ALLE Dateien (auch ftp-uploads) im ordner "media" und die Mediathek nur sachen, die auch über sie hochgeladen, das heißt in die datenbank eingetragen wurden?
Warum wurde das Modul als einziges mit einem Extramenueintrag (also nicht nur unter der Modulübersicht) erstellt?

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »jottjott« (22. Juni 2009, 19:36)


Werbung

Ähnliche Themen

Verwendete Tags

ibrowser, mediathek